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Preface

Preface

This section describes the audience for, the organization of, and conventions used in this 
document. It also identifies related documentation and explains how to access electronic 
documentation. 

Audience

This document is written for technical people who have basic understanding, familiarity 
and experience with network test and measurement equipment.  

Conventions

The following conventions and notations are used in this document:   

Note: This symbol means take note. Notes contain helpful suggestions or references to 
additional information and material.

Caution:  This symbol means be careful.  In this situation, you might do something that 
could result in equipment damage or loss of data.

Warning: This symbol means danger. You are in a situation that could cause bodily 
injury. Before you work on any equipment, be aware of the hazards involved with 
electrical circuitry and be familiar with the standard practices for preventing accidents.

Obtaining the Latest Documentation and Software

Please visit the ThinkRF website at http://www.thinkrf.com/documentation to obtain 
the latest documentation. Latest software and firmware releases are also available on the
ThinkRF website at http://www.thinkrf.com/download.

Document Feedback

Please send your comments about this document or any ThinkRF documentation to 
support@thinkrf.com.

We appreciate your feedback. 
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Preface

Obtaining Technical Assistance

For all customers who hold a valid end-user license, ThinkRF provides technical 
assistance 9 AM to 5 PM Eastern Time, Monday to Friday. Contact us at 
support@thinkrf.com or by calling +1.613.369.5104. 

Before contacting support, please have the following information available:

 WSA5000 serial number which is located on the identification label on the 
WSA5000's underside.

 The firmware version running on the WSA5000.

 Versions of ThinkRF software you are using, including the API libraries to third-
party applications.   

 The operating system and version you are using.
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Overview of the WSA5000 Real Time Spectrum Analyzer

Overview of the WSA5000 Real Time Spectrum 
Analyzer

The WSA5000 Real Time Spectrum Analyzer (RTSA) is a full-featured spectrum analysis
application designed to work with the WSA5000 Wireless Signal Analyzer. The RTSA 
application provides standard spectrum analysis features including frequency controls, 
marker functions, and multi-trace capabilities. 

The WSA5000 Wireless Signal Analyzer is a high-performance software-defined RF 
receiver, digitizer and analyzer.  With patent-pending software-defined RF receiver 
technology, the WSA5000 provides industry leading combined sensitivity, tuning range, 
instantaneous bandwidth (IBW) and scan rate. It has a hybrid RF receiver front-end 
(RFE) combining super-heterodyne, direct-conversion and direct digitization technologies
with both wide-band and narrow-band ADCs. Additionally, it provides hardware-based 
triggering and capture control, thereby enabling sophisticated sweeping and real-time 
capture.  

The WSA5000 RTSA can be used to measure signals such as Wi-Fi, Bluetooth, and LTE,
and markers can be used to track specific frequencies. Sophisticated FPGA-based level 
triggers within the WSA5000 Wireless Signal Analyzer enables the capture of elusive, 
time-varying signals across an instantaneous bandwidth of up to 100 MHz. The record-
and-playback feature allows you to capture signal data and store it, and replay the 
captured signal at a later time. In addition, you can export captured data to a CSV file for 
further processing.  

The WSA5000 RTSA application includes an intuitive user interface that incorporates a 
full set of controls for fast and simple control of application features. Fluid mouse 
navigation over the plot area allows you to quickly view the entire spectrum and easily 
zoom into areas of interest. 

The WSA500 RTSA application is built on the PyRF development framework, and is 
open-source under BSD licensing. PyRF handles the low-level details of real-time 
acquisition, signal processing and visualization, and provides feature-rich libraries, 
sample applications and source code, all specific to the requirements of signal analysis. 
For more information, visit the PyRF site at http://www.pyrf.org/.
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Overview of the WSA5000 Real Time Spectrum Analyzer

WSA5000 RTSA User Interface 

The WSA5000 RTSA user interface provides controls to manage the frequency and 
amplitude display, the RFE mode of the WSA5000 Wireless Signal Analyzer, trace 
capabilities, multiple plots such as spectrogram and raw IQ data, as well as 
measurement tools. 

Note: This section provides an overview of the WSA5000 RTSA user interface.  Please 
refer to the Configuring the WSA5000 RTSA Application  section for details on how to 
use individual settings and the options for each control.  
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Overview of the WSA5000 Real Time Spectrum Analyzer

Frequency Control Area  

The Frequency Control area contains parameters for defining the frequency bandwidth 
for signal monitoring.

Parameter Function

Mode Defines the Radio Front End (RFE) mode of the WSA5000 
Wireless Signal Analyzer, and the instantaneous bandwidth.  
Available options are:

• Sweep (40 MHz steps)
• Sweep (100 MHz steps)
• 100 MHz span
• 40 MHz span
• 10 MHz span
• 0.1 MHz span (high dynamic range)
• 0-50 MHz (no tuning)
• 100 MHz IQ input (no tuning)

Center Defines the center point of the frequency to be monitored, in 
MHz. Default value is 2450.00 MHz. 

Span Defines the frequency span to be monitored (sweep modes 
only). Changing this value  changes the Start and Stop values
Default value is 125.0 MHz.

Start Defines the beginning of the frequency range to be monitored 
(sweep modes only). Changing this value changes the Span 
value. 

Stop Defines the end of the frequency range to be monitored 
(sweep modes only). Changing this value changes the Span 
value. 

Adjust Sets the interval of incrementation for the Center, Span, Start 
and Stop fields (for up/down arrows). Default value is 10 MHz.

RBW Defines the Resolution Bandwidth (that is, determines the 
frequency between two adjacent bins in a given trace). Default 
value is 488.28 kHz.

Measurement Control Area  

The Measurement Control area contains parameters for identifying measurements for a 
sub-section of the signal being monitored.  

Parameter Function

Channel Power Enables or disables selection of a sub-band of the existing 
spectrum on the plot area, and measurement of the sub-band's
channel power.  

Horizontal Cursor Enables or disables display of a horizontal marker on the plot 
area at a specific power level.  
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Overview of the WSA5000 Real Time Spectrum Analyzer

Amplitude Control Area  

The Amplitude Control area contains parameters for defining the amplitude range for 
signal monitoring. 

Parameter Function

Reference Level Defines the maximum power level for the monitored signal. 
Default value is 0 dBm. 

Minimum Level Defines the minimum power level for the monitored signal. 
Default value is -160 dBm. 

Offset Defines the offset power level applied to the signal. This offset 
is only applied in the software; the actual signal is not 
changed. 

Attenuator Enables or disables the RFE's 20 dB attenuation of the 
incoming signal. 

Device Control Area  

The Device Control area contains parameters related to the WSA5000 Wireless Signal 
Analyzer operation. 

Parameter Function

DDC Defines the decimation rate of the signal (that is, the 
decimation rate of raw samples applied in the FPGA). This 
parameter is disabled for Sweep SH and Sweep ZIF modes. 

FShift Defines the value used for frequency shifting. This parameter 
is disabled for Sweep SH and Sweep ZIF modes.

PLL Ref Specifies the synchronization source for the PLL reference 
clock. Available options are: 

• Internal
• External 

IQ Path Specifies the path for analog IQ signals. Available options are:
• Digitizer (internal WSA5000 digitizer) 
• Connector (external digitizer through I/Q output 

connectors)

Level Trigger Enables or disables triggering on signals of interest (only 
enabled for ZIF, SH and SHN modes).

Start Defines the minimum frequency threshold for triggering signal 
capture.  

Stop Defines the maximum frequency threshold for triggering signal 
capture. 

Level Defines the power level for triggering signal capture.
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Overview of the WSA5000 Real Time Spectrum Analyzer

Trace Control Area  

The Trace Control area contains parameters for setting traces and adding markers on the
signal display. You can add up to three traces to the signal display, and up to two 
markers. 

Parameter Function

Defines the color displayed for the trace. 

 

Defines the display mode for the trace. Available options are:
• Live
• Max
• Min
• Average
• Off 

Pause Pauses the trace display.

Clear Trace Resets the trace display.

+ Marker Adds a marker to the signal display.   
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Getting Started with the WSA5000 RTSA Software

Getting Started with the WSA5000 RTSA 
Software

Before installing the WSA5000 Real Time Spectrum Analyzer software, ensure that your 
PC meets the minimum system requirements:

• Operating System:

▪ Windows XP 

▪ Windows 7 (32-bit or 64-bit)

▪ Windows 8 (32-bit or 64-bit)

• RAM:  2 gigabytes (GB)

• Hard Disk: 1 gigabyte (GB) available

Note: You must have an Internet connection to download the WSA5000 RTSA software 
from the ThinkRF website.

Installing the WSA5000 RTSA Software

You must download the WSA5000 RTSA installer from the ThinkRF website to install the 
software on your computer. 

1. Open a web browser, and go to http://thinkrf.com/download.

2. Click the Download button to download the zip file for the latest software and 
firmware release (for example, WSA5000 RTSA Release 140909).

3. When you have downloaded the zip file, extract the contents to a folder of your 
choice.

4. Double-click on the pyrf_RTSA_Installer_x.y.z.exe file to launch the Setup 
Wizard, and follow the prompts to select your installation options and install the 
software. 

5. On the Welcome screen, click Next.

6. On the License Agreement screen, select “I accept the agreement” and click 
Next. 

7. On the Select Destination Location screen, specify a path for software installation
(or keep the default path) and click Next.

8. On the Select Component screen, select the software components you want to 
install and click Next.

9. On the Select Start Menu Folder screen, specify a path for the program shortcut 
in the Start Menu (or keep the default) and click Next. 
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Getting Started with the WSA5000 RTSA Software

10. On the Select Additional Tasks screen, specify whether you want the installer to 
create a desktop shortcut to the WSA 5000 RTSA application, and click Next. 

11. On the Ready to Install screen, review your installation settings.  Click Install to 
proceed with the installation, or Back to change your settings. 

12. When the Setup Wizard has completed software installation, click Finish to exit 
the Wizard.
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Getting Started with the WSA5000 RTSA Software

Connecting to a WSA5000 Device 

You must connect to a WSA5000 Wireless Signal Analyzer to view data in the 
WSA5000 RTSA application. The application detects any WSA5000 devices that are on 
the same subnet of your network, but you must explicitly select one to complete the 
connection. 

1. Launch the WSA5000 RTSA application from the Start menu or desktop icon (if 
installed). 

The application displays the “Open Device” window. 

2. Select a device from the list of auto-discovered devices. You can click the 
Refresh button to obtain an updated list of devices.

Alternatively,  you can enter the IP address of the WSA5000 device manually in 
the “Manually Enter Device IP” field. 

3. Click Connect.

The WSA5000 RTSA application connects to the WSA5000 device and displays 
the user interface. By default, the WSA5000 acquires and measures signals 
automatically.  
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Configuring the WSA5000 RTSA Application 

Configuring the WSA5000 RTSA Application 

The WSA5000 Real Time Spectrum Analyzer application provides several options for 
controlling and displaying signal capture through the WSA5000 Wireless Signal Analyzer,
including RFE mode, frequency and amplitude controls, trigger levels, and trace display. 

Configuring Frequency Settings  

You can set frequency for the signal to be monitored using the parameters in the 
Frequency Control area. You can enter values for these fields manually, or use the 
up/down arrows to increase or decrease the values. Alternatively, you can also 
click-and-drag the mouse over the plot display area to change the frequency to be 
monitored. 

As you specify or change these values, the axes on the signal waveform display adjust 
accordingly. A vertical line on the plot display indicates the center point of the frequency 
band being monitored. 

1. In the Frequency Control area, select the device RFE mode (with corresponding 
instantaneous bandwidth) from the drop-down list in the Mode field: 

Device Mode Description 

Sweep (40 MHz steps) 40 MHz segments (instantaneous bandwidth), in 
sweep mode.

Sweep (100 MHz 
steps)

100 MHz segments (instantaneous bandwidth), in 
sweep mode.

100 MHz span 100 MHz span (instantaneous bandwidth) in fixed 
mode.  

40 MHz span 40 MHz span (instantaneous bandwidth) in fixed 
mode.  

10 MHz span 10 MHz span (instantaneous bandwidth) in fixed 
mode.  

0.1 MHz span (high 
dynamic range)

100 kHz span (instantaneous bandwidth) in fixed 
mode; best for low-power signals.

0-50 MHz (no tuning) 0-50 MHz span; no tuning. Dedicated to RF IN 
connector (when device is used as a digitizer only). 

100 MHz IQ input (no 
tuning)

100 MHz span; no tuning. IQ In mode (for external IQ 
input).  

2. Set the central point of the frequency band you want to monitor by specifying a 
value in the Center field.   

3. For Sweep modes only, specify the frequency sweep range. You can specify the 
range in two ways:
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Configuring the WSA5000 RTSA Application 

• specify start/stop frequency values in the Start and Stop fields (either 
manually or using the up/down arrows) 

• specify a value in the Span field (either manually or using the up/down 
arrows) – this value is applied relative to the center frequency value

4. Optionally, specify the interval of frequency control field values by setting the 
Adjust field.  

5. Set the Resolution Bandwidth for the signal by selecting a value from the 
drop-down list in the RBW field.  

Configuring Channel Measurement Settings  

You can define a section of the signal being monitored and view the channel power of 
that section, by enabling the Channel Power in the Measurement Control area. 

1. In the Measurement Control area, select a sub-section of the signal by enabling 
the Channel Power field. 

The plot display shows two vertical lines to define the frequency boundaries of the 
channel (default position is at the center of current spectrum), and the background 
color between the boundaries changes. The measured channel power is displayed 
above the signal plot. 

2. Optionally, change the span of the channel by clicking and dragging the left or 
right boundary of the channel on the plot display.  

3. Optionally, insert a horizontal line on the plot display to mark a specific power 
level by selecting the Horizontal Cursor box. 

You can change the position of the horizontal line by clicking and dragging the 
line on the plot display, or by changing the power level in the field beside by the 
Horizontal Cursor box. 
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Configuring the WSA5000 RTSA Application 

Configuring Amplitude Settings  

You can set the amplitude for the signal to be monitored using the parameters in the 
Amplitude Control area. You can enter values for these fields manually, or use the 
up/down arrows to increase or decrease the values.   

1. In the Amplitude Control area, set the maximum power level for input signals by 
specifying a value in the Reference Level field.   

2. Set the minimum power level for input signals by specifying a value in the 
Minimum Level field. 

3. Optionally, configure a power offset for the signal display by specifying a value in 
the Offset field. Note that the offset is applied in software only and is reflected in 
the signal display (including any recorded signals for playback); however, the 
input signal itself is not affected. 

4. Optionally, enable the device's 20 dB attenuation of the incoming signal by 
selecting the Attenuator box (enabled by default).

Configuring the Device Control Settings  

You can ensure signal information is captured and displayed in a manner appropriate to 
your application using the parameters in the Device Control area.

1. Set the decimation rate for the signal by selecting a value from the drop-down list
in the DDC field. (Disabled for sweep modes.)

2. Set the value of the frequency shift in the FShift field. A negative value 
corresponds to a left shift. (Disabled for sweep modes.) 

3. Specify the synchronization source for the PLL reference clock by selecting an 
option from the drop-down list in the PLL Ref field (either Internal or External).

4. Specify the IQ output path by selecting an option from the drop-down list in the 
IQ Path field (either Digitizer or Connector).

Note: If you select the “Connector” option for IQ Path, you are using the device in Down-
Converter mode and bypassing all internal digitizing functions. The signal display area 
disappears from the interface when you select this option.

5. Enable signal capture triggering by selecting the Level Trigger box. (Enabled 
only for fixed modes of 100 MHz, 40 MHz or 10 MHz instantaneous bandwidth.)

The plot display shows a rectangle representing default trigger parameters: 
minimum frequency (left boundary), maximum frequency (right boundary), and 
power level (top boundary).  
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6. If you have enabled signal capture triggering, set the trigger threshold values:  

• specify the minimum frequency in the Start field 

• specify the maximum frequency in the Stop  field

• specify the power level in the Level field 

You can also set the trigger parameters by clicking and dragging the left, right 
and top boundaries to change the minimum frequency, maximum frequency and 
power level respectively. 

Configuring Traces for the Signal Display

You can configure up to three active traces in the signal display using the parameters in 
the Trace Control area. By default, the first trace is set to display all values captured for 
the signal. The following procedure applies to each trace. 

1. In the Trace Control area, select the display mode for the trace from the drop-
down list in the field beside the trace label: 

Trace Mode Description 

Live The trace plots all values captured for the signal. 

Max The trace plots only the maximum values captured for the 
signal. 

Min The trace plots only the minimum values captured for the 
signal. 

Average The trace plots the average values captured for the signal over
the number of samples specified.  When you select this mode, 
a new field appears beside the mode field where you must 
specify the number of samples to be used for averaging. 

Off Trace is removed from the display. 
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2. Optionally, change the color of the trace by clicking on the color icon beside the 
display mode button, and select a color from the palette. 

3. Select the Pause box to freeze the trace display. 

4. Click the Clear Trace button to reset the trace display.     

5. Repeat steps 1 - 3 for additional traces. 

Adding Markers to the Signal Display

You can add up to two markers to the signal display. The markers can be associated with
any trace on the display. 

By default, the marker is displayed at the center frequency, and moves on the waveform 
as it measures power levels. The frequency and power values at the marker point are 
displayed at the top of the signal display window. 

You can change the marker position by clicking and dragging the marker to the left or to 
the right.  

1. Select a trace in the Trace Control area and click the +Marker button. 

2. Click the Peak button to position the marker at the highest peak signal. 

3. Click the Peak Left button to position the marker at the highest peak signal to the
left of the current marker position.

4. Click the Peak Right button to position the marker at the highest peak signal to 
the right of the current marker position.  

5. Click the Center button to change the center frequency to match the current 
marker position.

6. Repeat steps 1 - 5 to add a second marker to the signal display.  

7. To remove a marker, click on the – button in the M1 or M2 area. 

Displaying I/Q Plots  

You can view an I/Q plot display of captured signal information (this view is particularly 
useful when using the device in IQIN mode). The I/Q plots appear below the main signal 
display in the interface, and include two plots:

 Constellation plot (left side) shows the in-phase (I data) vs quadrature (Q data) 
plot

 Time domain plot (right side): shows a trace for the In-phase (I data in green) and
a trace for the quadrature (Q data in red, if available in the mode) 

1. Open the View menu, and select I/Q Plots from the drop-down menu. 

The I/Q plots appear below the main signal waveform display.  

2. To hide the I/Q plots, open the View menu and deselect the I/Q Plots option. 

ThinkRF Real Time Spectrum Analyzer User Guide 18



Configuring the WSA5000 RTSA Application 

Displaying the Spectrogram

You can view a spectrogram display of captured signal information. The spectrogram 
displays spectrum changes over time in a three-dimensional view. Time is displayed on 
the horizontal axis, and frequency on the vertical axis. The amplitude of the frequency 
components is expressed by color.  

1. Open the View menu, and select Spectrogram from the drop-down menu. 

The spectrogram plot appears below the main signal waveform display.  

2. Optionally, you can enhance the display of the signal(s) of interest by sliding the 
triangles on the color palette (to the left of the display) to adjust the threshold at 
which the signal changes color. This allows the user to specify colors for each 
noise floor level.

3. To hide the Spectrogram plot, open the View menu and deselect the 
Spectrogram Plot option. 
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Displaying the Persistence Plot

You can view a persistence plot display of captured signal information. The persistence 
plot is a view of how long a signal remains present; as it grows weaker, it fades in color.  
Amplitude is displayed on the horizontal axis, and frequency on the vertical axis.

1. Open the View menu, and select Persistence Plot  from the drop-down menu. 

The persistence plot appears below the main signal waveform display.  

2. Optionally, you can enhance the display of the signal(s) of interest by sliding the 
triangles on the color palette (to the left of the display) to adjust the threshold at 
which the signal changes color. This allows the user to choose the colors that the
persistence plot uses to represent the shades of persistence of the spectrum. 

3. To hide the Persistence plot, open the View menu and deselect the Persistence 
Plot option. 
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Capturing Data from the WSA5000 RTSA 
Application 

In addition to viewing signal data in real time on the WSA5000 Real Time Spectrum 
Analyzer application, you can also capture and store signal information for playback, or 
write the data to a CSV file for further processing by another application.  

Caution:  The WSA5000 RTSA application does not impose a limit on the file size for 
signal recording or writing to a CSV file. If recording is not explicitly stopped, the 
application continues to write data to the file until the local hard drive is full. 

Recording a Signal for Playback

The WSA5000 RTSA application allows you to record a signal and save the file for future 
playback. All recorded signals are stored on the PC that is hosting the WSA5000 RTSA 
application. 

1. To begin recording the signal data, open the File menu and select the Start 
Recording option. 

The RTSA application begins recording the signal data displayed in the interface.

2. To stop recording the signal data, open the File menu and select the Stop 
Recording option. 

The WSA5000 RTSA application stops recording the signal data displayed in the 
interface, and stores the recorded file (with .vrt extension) in the 
pyrf/RTSA/Scripts/dist directory.  

Playing Back a Recorded Signal

The WSA5000 RTSA application allows you to play back a previously recorded signal. 
The .vrt file must be located on the PC that is hosting the RTSA application. 

1. Open the File menu and select the Playback Recording option. 

The application opens a Explorer window, defaulting to the location of the 
pyrf/RTSA/Scripts/dist directory (Note you can move to another folder 
destination using the explorer window). 

2. Select the .vrt file you want to play, and click Open. 

The signal display area plays back the recorded signal continuously, in loopback 
mode. 

Note: You can add traces and markers to the signal playback display. Frequency and 
device controls are disabled. 
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3. To stop playback of the recorded file, you must do one of the following:

• open a different file for playback (repeat step 1)

• reconnect to the device (open the File menu and select the Open 
Device option)

• exit the WSA5000 RTSA application 

Exporting Signal Data to a CSV File

The WSA5000 RTSA application allows you to capture and export signal data to a CSV 
file for further processing by another application. All recorded data is stored on the PC 
that is hosting the WSA5000 RTSA application. 

The CSV file contains the following information about the captured signal:

Parameter Description 

mode The RFE mode of the device during signal capture. Possible 
values are:

• ZIF (100 MHz instantaneous bandwidth)
• SH (40 MHz instantaneous bandwidth)
• SHN (10 MHz instantaneous bandwidth
• HDR (100 kHz instantaneous bandwidth)
• DD (0-50 MHz instantaneous bandwidth; no tuning)
• IQIN (100 MHz instantaneous bandwidth; no tuning)

fstart The start of the frequency range (Hz). 

fstop The end of the frequency range (Hz). 

size Number of data points (power values) captured for the signal in
the CSV file. 

timestamp ISO time stamp representing time at which the data was 
displayed in the RTSA 

<data> A series of integers representing the power value of the 
captured signal for each sample. The number of data samples 
corresponds to the value specified in the size parameter. 

1. To begin capture and export of the signal data, open the File menu and select 
the Start Exporting CSV option. 

The RTSA application opens an Explorer dialog box to specify the name and 
location of the CSV file. 

2. Specify a name and storage location for the file and click Save. By default, the 
system stores the file (csv-0000.csv) in the the pyrf/RTSA/Scripts/dist 
directory. The system begins writing the signal data to the CSV file at the 
specified location. 

3. To stop writing signal data to the CSV file, open the File menu and select the 
Stop Exporting CSV option. 

The WSA5000 RTSA application stops writing the signal data to the CSV file.  
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